WMI Error 1065 processing group policy

Ever have one of those days?  Among all the random things the corporate beast threw at me, I encountered a wonderful WMI error generated by a GPO refresh.  Here’s the error:

Log Name:      System
Source:        Microsoft-Windows-GroupPolicy
Date:          11/5/2012 10:29:20 AM
Event ID:      1065
Task Category: None
Level:         Error
Keywords:  
User:          SYSTEM
Computer:      THISDARNMACHINE
Description:
The processing of Group Policy failed. Windows could not evaluate the Windows Management Instrumentation (WMI) filter for the Group Policy object cn={C60D9FEB-D1D6-40B5-8A53-1541AE44170B},cn=policies,cn=system,DC=mydomain. This could be caused by RSOP being disabled  or Windows Management Instrumentation (WMI) service being disabled, stopped, or other WMI errors. Make sure the WMI service is started and the startup type is set to automatic. New Group Policy objects or settings will not process until this event has been resolved.

Looks like the WMI filters on certain group policy objects are preventing them from being applied.  Being that I’m not sure which objects have WMI filters, I’d best resolve this.  After some digging, here’s the process used to resolve the WMI issue (original source):

  1. Log onto Windows 7 with an administrator account, click Start, type services.msc in the Start Search box and press Enter.
  2. In the right pane of the Service console, locate and right-click Windows Management Instrumentation, and then select Stop to stop the service.
  3. Start Windows Explorer, and then locate the %SystemRoot%System32WbemRepository folder.
  4. Backup and delete all the files in the %SystemRoot%System32WbemRepository folder.
  5. Restart the computer.

 The files that were deleted will be re-created when the computer restarts.  Note: The Windows Management Instrumentation service starts automatically when you restart the computer.  If the issue persists, please re-register WMI DLL files and re-compile WMI mof files to check if the issue can be resolved. Here are the detailed steps:

  1. Disable and stop the Windows Management Instrumentation service.
  2. Right-click Command Prompt and select Run as Administrator.
  3. In the Command Prompt, type cd %windir%system32wbem and press Enter.
  4. Type for /f %s in (‘dir /b *.dll’) do regsvr32 /s %s and press Enter to re-register WMI DLL files.
  5. After completed, type for /f %s in (‘dir /b *.mof’) do mofcomp %s and press Enter to re-compile WMI mof files.
  6. After that, type the command wmiprvse /regserver and press Enter.
  7. Start the Windows Management Instrumentation service and change the Startup Type back to Automatic.

Well this took care of the original WMI error causing all policies to fail.  Now I’m down to just not being able to apply the new IE group policy.

Log Name:      System
Source:        Microsoft-Windows-GroupPolicy
Date:          11/5/2012 11:43:41 AM
Event ID:      1085
Task Category: None
Level:         Warning
Keywords:  
User:          SYSTEM
Computer:      THISDARNCOMPUTER
Description:
Windows failed to apply the Internet Explorer Zonemapping settings. Internet Explorer Zonemapping settings might have its own log file. Please click on the “More information” link.

This one was simply fixed by fixing the zone entry where I neglected to add the zone number – oops!

(Migrated from https://normesysadmin.blogspot.com 6/16/16)

Leave a Comment

Your email address will not be published. Required fields are marked *